T3 Community Discussion & Support

Let's build the best free Joomla template framework, together!
  1. Robert
  2. General Discussion
  3. Tuesday, December 10 2013, 10:23 AM
  4.  Subscribe via email
Hi,

I am a paying member of the commercial part of this framework. And Iv sent several tickets to them with no solutions.

I was happy when updating to t3-v.2.0. I lovet it.

But then the problem started. As a developer I always turn the developer mode to "ON". Now the page would not load. and its giving me a:

"Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 64 bytes) "

Then I Increased php memory from 64m to 128m with a php.ini file. And the page loads normal again with the developer mode on. Im happy again.

Then I finished my project, turns of the developer mode and clicks the compile less button. And guess what? The same error came back.

Ok, back to php.ini. I increased the php memory to over 1000m just to clear it out , and I increased the maximum loading time from 30 to 3000.
But the error where still there.

I even tried to update the plugin to the 2.0.1 version. No help.

What to do?

Manual and local less compiling is out of the picture.
Comment
There are no comments made yet.
Accepted Answer
Paul Accepted Answer Pending Moderation
0
Votes
Undo
Hi

Have you tried testing the memory issue by disabling other extensions e.g. an image handling module that resizes - something along those lines
If you can reduce the memory used elsewhere then you will have a better understand of what is happening - especially as its 64 bytes only

Just a thought :)

Cheers
Paul
Comment
There are no comments made yet.
  1. more than a month ago
  2. General Discussion
  3. # Permalink
Admin Accepted Answer Pending Moderation
0
Votes
Undo
Hi Robert,

You can try to increase the memory limit 128MB and try again.
Comment
There are no comments made yet.
  1. more than a month ago
  2. General Discussion
  3. # 1
Robert Accepted Answer Pending Moderation
0
Votes
Undo
Hi Super User,

This is my php settings at the moment:

memory_limit 256M;
max_execution_time 3000;

These settings will make the site work in developer mode, but it will not compile the less from backend when I turn of developer mode.

I run the latest versions of framework.
Comment
There are no comments made yet.
  1. more than a month ago
  2. General Discussion
  3. # 2
Admin Accepted Answer Pending Moderation
0
Votes
Undo
Thank Paul,

@Robert, you can clone your website to localhost and try to compile it.
I think your server may not allow to allocate 256MB to run your website.
As most of T3 theme will require 128MB only.
Comment
There are no comments made yet.
  1. more than a month ago
  2. General Discussion
  3. # 3
Robert Accepted Answer Pending Moderation
0
Votes
Undo
Hello,

I solved it by getting the host to increase it to 128m. PHP.ini only helps for the developer-mode. NOT the compiling from backend.
Comment
There are no comments made yet.
  1. more than a month ago
  2. General Discussion
  3. # 4
Paul Accepted Answer Pending Moderation
0
Votes
Undo
ah had a feeling it was a memory related issue - thanks for posting back
Asking the host to try this would have been my next suggestion :)

Glad it worked for you

Cheers
Paul
Comment
There are no comments made yet.
  1. more than a month ago
  2. General Discussion
  3. # 5
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.