T3 Community Discussion & Support

Let's build the best free Joomla template framework, together!
  1. Pawel
  2. General Discussion
  3. Tuesday, July 30 2013, 06:09 PM
  4.  Subscribe via email
Hi.
I have a problem with image caption.
It is displayed multiple times. Sometimes double, sometimes triple and even more.
Problem apears only after enabling cache. Without caching it works fine.

At the begining, captions were not displayed at all. So I added
JHtml::_('behavior.caption');
in components\com_content\controller.php. As someone wrote here http://www.joomlart.com/forums/showthread.php?87096-Image-Caption-not-working-J3.1.1-Jand-a-Blank-1.2.4
After it captions appeared, but multiple times (when cache enabled).
Here is screenshot " >http://m51.stronazen.pl/images/planck.jpg" >" >http://m51.stronazen.pl/images/planck.jpg" >" >http://m51.stronazen.pl/images/planck.jpg" >" >http://m51.stronazen.pl/images/planck.jpg
And here is the website
with cache enabled : http://m51.stronazen.pl/13-wpisy/astronomia/11-poczatekwszystkiego
and with cache disabled: http://www.m51.pl/13-wpisy/astronomia/11-dlaczego-wielki-wybuch

sorry for poor english :P
Comment
There are no comments made yet.
Admin Accepted Answer Pending Moderation
0
Votes
Undo
Hi Pawel,

You can try this way:

Remove the code in suggestion in forum.

Open \plugins\system\t3\base\html\com_content\article\default.php

And add the JHtml::_('behavior.caption'); at line 28, just before the '?>' mark.

Or if you do not want to modify the T3 core, you can overwrite this file in your template by copy the file above
then place to your template at:
/templates/[template_name]/html/com_content/article/default.php

Then you can modify it and add JHtml::_('behavior.caption');

Regards
Comment
There are no comments made yet.
  1. more than a month ago
  2. General Discussion
  3. # 1
Pawel Accepted Answer Pending Moderation
0
Votes
Undo
Thanks for answer, but unfortunately it doesnt work. Still same problem. Triple image captions.
Comment
There are no comments made yet.
  1. more than a month ago
  2. General Discussion
  3. # 2
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.