We moved to new unified forum!

Please post all new support queries in our New Forum.

T3 Community Discussion & Support

Let's build the best free Joomla template framework, together!
  1. Admin
  2. Hole-in-One Sherlock Holmes The Voice
  3. Announcement
  4. Wednesday, 01 July 2015
  5.  Subscribe via email
Hi guys,
We would like to announce the release of T3 Framework version 2.4.9. This release's to fix an issue of T3.

For more detail of the release, please check out the following references:



If you have any comment/suggestion, leave us a message in the discussion page: http://t3-framework.org/discussions.html
There are no comments made yet.
Accepted Answer Pending Moderation
I'd upgrade gladly to T3 2.4.9...if I could do it!
I have been developing several sites using t3_bs3_blank as template and, of course, the t3 framework plugin.
I am using Joomla 3.4.0 stable (ember), PHP 5.4.21, a customized version of the t3_bs3_blank 2.1.4 template and T3 Framework plugin version 2.3.2
(The latter are badly out of date, I know, but there is a reason : whenever I tried to update thru the Joomla updater, it gave me errors such as "incompatible plugin" and so on. BTW, I spotted a " .../j16/..." in the midst of the old update URL, which strikes me as curious for a j30 update)

So, based on the "if it ain't broke, don't fix it" principle, I've let the update issue lie.

However, lately the site started malfunctioning when viewed on tablets.
On desktop computers, everything still works OK, as it always had.
On iPads, however, the dropdown menus have stopped working since the upgrade to iOS 8.4: if you click on the menu heading, it opens the dropdown menu, but if you tap on any item in that dropdown menu, it doesn't load the page the item points to.
So, I decided to upgrade the plugin to 2.4.9.
And here began the pains . I'll list them item by item :

• The system seemed uncertain if there was an upgrade available or not. While Joomla Control > Maintenance panel advised of the upgrades, the Template Manager > Edit Style page happily said "Congrats! You are using the latest version of T3 Framework ! Your Version is 2.3.2" on my local, development version (running on MAMP 3.0.3 on my iMac)...no comment. The online machine showed upgrades available in both positions. Maybe there are security settings in my LAN that blocks access to the ports Joomla uses (I doubt it, from what I know J! uses standard http and ftp ports, which are open), or maybe the failed updates have left the database "dirty" - I don't know.
• Upgrade via control panel > Maintenance does not work. It says incompatible plugin or something like that.
• After reading the forums, I tried installing JA Extension Manager (JAEM).
⁃ On the local machine JAEM installed but didn't work ("Please update the service setting or contact with service provider.";).
⁃ On the online machine JAEM installation crashed with a "file does not exist" error.
⁃ A quick tour of your forums then revealed that while you can download JAEM for free, it seems to be useless unless your site is registered with JoomlArt, which requires a paid membership (proof is here - https://www.joomlart.com/forums/showthread.php?99576-Error-Please-update-the-service-setting-or-contact-with-service-provider)
• So, I resorted to manual upgrade : I downloaded plg_system_t3.v2.4.9.zip from the T3 downloads site, and installed it on the online site thru Joomla's extension manager...
• KER-POW! The menus no longer dropped down, no matter the browser or device you used (you could only select the menu heading), and the homepage slideshow (YESlider) just disappeared.

I had to reinstall the site in a hurry from a backup I prudently made a few hours before.

I don't understand why it crashes that way:
The settings are the same - I checked.
I have customized CSS files (of course, since t3_bs3_blank is MADE to be customized), but they are all in the /templates/t3_bs3_blank folder, mainly contained in the custom.css and template.css files. I never touched any file in the /plugins folder, not to mention the /plugins/t3 folder, which is the one where I understand the plugin installs all of it styles.

So : Any idea about what to do to upgrade, or at least to make the menus work on tablets too ?
There are no comments made yet.
  1. more than a month ago
  2. Announcement
  3. # 1
  • Page :
  • 1

There are no replies made for this post yet.
However, you are not allowed to reply to this post.